PHP 5.4.17 est disponible
Près de 20 bogues de fonctionnement du langage corrigés

Le , par kdmbella, Expert éminent
PHP version 5.4.17 est disponible. Cette version corrige près de 20 bogues de fonctionnement du langage, notamment :
  • le crash lors de l’utilisation non sérialisée d’une instance de DatePeriod ;
  • le problème de segmentation lors de l’instanciation de 2 PDO persistants sur le même serveur de base de données ;
  • la non possibilité de se connecter à SQL Server 2008 avec PDO dblib ;
  • la non connexion à Azure SQL via pdo_dblib ;
  • le retour de mauvaises valeurs pour les champs numérique dans Firebird via PDO_dblib ;
  • la méthode getColumnMeta() (de PDO_mysql) qui ne retourne pas de type natif pour les types BIT, TINYINT et YEAR ;
  • le dépassement de tampon dans _pdo_pgsql_error de PDO_pgsql ;
  • etc.


Les développeurs sont vivement encouragés à migrer vers cette nouvelle version afin de se prémunir de ces bogues.

Pour télécharger les sources se rendre sur la page de téléchargement à cette adresse

La liste complète des changements dans cette version est consultable à l’adresse suivante.

Source : site officiel de PHP


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de kdmbella kdmbella - Expert éminent https://www.developpez.com
le 13/07/2013 à 14:43
L'équipe de développement de PHP vient d'annoncer la disponibilité immédiate de la version 5.3.27 du langage en parallèle avec la fin du cycle de vie de la branche 5.3 de celui-ci. Cette version comprend la résolution d'une dizaine de bogues incluant un problème de sécurité au niveau du parseur XML. Il s'agit donc de la dernière release concernant la branche 5.3, le reste du temps étant destiné aux mises à jour de sécurité. Les développeurs sont donc invités à migrer rapidement vers la branche 5.4 ou la branche 5.5 du langage.

Concernant les corrections de bogues dans cette version, nous pouvons citer entre autres :
  • l'échec de la compilation sur netbsd ;
  • le crash lors de l'usage d'une instance non sérailisée (unserialised) de DatePeriod ;
  • le Buffer overflow dans _pdo_pgsql_error (PDO_pgsql) ;
  • problème de tas (heap corruption) dans le parser XML ;
  • le support du type enum dans pg_convert (pgsql) ;
  • etc.


La liste complète et détaillée des changements dans cette nouvelle version est consultable sur ce lien

Source : le site de PHP
Offres d'emploi IT
Data scientist senior H/F
Safran - Ile de France - Magny-les-Hameaux (Saclay)
Responsable transverse - engagement métiers H/F
Safran - Ile de France - Corbeil-Essonnes (91100)
Ingénieur H/F
Safran - Ile de France - Moissy-Cramayel (77550)

Voir plus d'offres Voir la carte des offres IT
Contacter le responsable de la rubrique PHP